RV Park Reviews

Welcome Guest ( Log In | Register )

 
Reply to this topicStart new topic
> Workhorse Chassis Brake Problems
Butch
post Sep 30 2008, 11:19 AM
Post #1


Advanced Member
******

Group: Members
Posts: 508
Joined: 23-July 05
From: New York State--Saratoga Area
Member No.: 3801



Just a question as it relates to Class A motorhomes, dated 2002-to date, who may have had, or are having brake problems with a Workhorse Chassis. There was a safety re-call in 2004-2005 on a brake problem as to brake caliper hang-up due to corrosion on the slide pins. In 2005 our chassis was checked, lubricated, and we were told we were okay. Now, we have a problem. On our most recent annual vacation, to our beloved State of Maine, in the State of New Hampshire, on a decline, the brake pedal, on initial application went to about two inches from the bottom of its travel, but did have brakes at this point. Stopped the unit and checked the system over only to find no visible problems. Proceeded at a slow pace and after about five applications of the brakes, the system returned to normal, and stayed that way for our trip to Maine. But before we left to return home we wanted someone to at least look at the system as we had three long steep declines to descend in the State of Vermont on route 9. A heavy duty truck brake center was located and after several hours of checking the brake system the master cylinder was found defective and replaced. At a cost of $ 1026.00 All seemed well until we were descending the last decline, returning home, the front brakes were not acting correctly and the ABS light was continually on. We were only 28 miles from home so we proceeded slow and carefully home. Made an appointment to have the system checked at our local Workhorse Service Center and was told the front brakes were burnt up and took the the speed sensors with them so that's why the ABS light was on. At this point the rear brakes were not the best either so we bit the bullet and stated replace them all completely...calipers...rotors...brake pads.....front wheel speed sensors, and all necessary seals. As our unit has a 2002 Workhorse chassis under a 2003 motorhome......you guessed it......it's out of warranty and the Great Workhorse chassis manufacturer wouldn't even offer any financial help at this point. The unit has 15,075 miles on it. All at a cost of $ 3375.00. As I see it, the brake problem was one in the same as the re-call in that the front calipers seized and the damage was done. At this point, I would not even consider another motorhome with a workhorse chassis, but the Ford gas chassis has its' brake problems also, both manufacturers are using light duty brake systems because of cost as it relates to the chassis selling price to the motorhome manufacturers. I guess the answer is buy at diesel pusher with air brakes.............now we are talking the big bucks....up front cost, parts, fuel, o what the heck....its only money!!!!!


--------------------
Butch & Kathy
and "Greta"
says, "me too !"
FMCA # F412606
User is offlineProfile CardPM
Go to the top of the page
+Quote Post
John Blue
post Sep 30 2008, 10:09 PM
Post #2


Advanced Member
******

Group: Members
Posts: 2174
Joined: 9-November 03
From: Brandon, FL.
Member No.: 214



Butch,

What a poor made system to fall apart at 15,000 miles. We read about this type of problems all the time with Workhorse units. I think everything they built will fail in a short time.

We have 80,000 plus miles on our clock and not one time have we every had a brake problem. I checked the pads and rotors (all four wheel) years ago at time we were changed out tires and could not see any change from new.

We have been down Vail pass in CO (10,666 feet) on I-70 and lots of others down hill runs with no problems. No wheel or bearing problem and we at 30,000 lbs. I guess the deal is how cheat can we build a motorhome.


--------------------
John
Brandon, Fl.
FMCA F-248693
Foretravel MH
Honda CRV tow
User is offlineProfile CardPM
Go to the top of the page
+Quote Post

Reply to this topicStart new topic
1 User(s) are reading this topic (1 Guests and 0 Anonymous Users)
0 Members:

 



Lo-Fi Version
RVParkReviews.com