Help - Search - Members - Calendar
Full Version: Generator Question
RV Park Reviews Campground Discussion Forum > RV Park and Campground Discussions > General Chat
Syl
2005 motor home ~ On a cool morning our Onan generator functioned normally, but later the same day when it was 80 plus degrees, it ran for 10 mins. or so, coughed and cut off. This failure to run in hot weather has been a pattern. Has anyone had a similar experience and/or do you have pearls of wisdom to share as to what might be the cause? Thanks.
dalsgal
Check your cooling system. It is overheating because it isn't cooling properly.
John Blue
First off I take it this is a diesel engine. If gas let me know.

Coolant system that are low on coolant or a bad coolant bulb will do this. Also check to see if you have good air flow coming through the radiator. The air should be warm, not hot.

Next problem is air in fuel line. If the fuel line is old or has a small pin hole leak it will pull in air, fuel will not leak out of this hole. The air will build up in high pressure pump and down it will go. On the next restart the air will be moved back to fuel tank by the fuel pump as you warm up the glow plugs (fuel pump runs at same time as glow plug heaters are on). System may run 5 to 10 mins but if air is leaking in it will start over again. Heat will expand fuel lines. Next how old is the fuel filter? If old change it and use a truck grade not a car grade filter. A good NAPA store can help you on this item.
jorjastandish
Thanks. How much will it cost to change the cooling system?
John Blue
Change it to what? laugh.gif
RFCN2
I took me a year to get my Onan 12,500 to not overheat. I had the service place change coolant, thermostat, and complained a number of times. As it turned out in the end the fan belts on many of these are hard to get at. So mechanics don't like to check them. Mine was in taters. They replaced it and it has not skipped a beat since.

Certainly true that you should check your fluid level to make sure you are not low on coolant, but also make sure your fan belt is OK.
Syl
>> Hi John, The MH is gas, not diesel. It's a 31C Winnie/Minnie 2005.



QUOTE(John Blue @ Jul 16 2011, 08:53 PM) *

First off I take it this is a diesel engine. If gas let me know.

Coolant system that are low on coolant or a bad coolant bulb will do this. Also check to see if you have good air flow coming through the radiator. The air should be warm, not hot.

Next problem is air in fuel line. If the fuel line is old or has a small pin hole leak it will pull in air, fuel will not leak out of this hole. The air will build up in high pressure pump and down it will go. On the next restart the air will be moved back to fuel tank by the fuel pump as you warm up the glow plugs (fuel pump runs at same time as glow plug heaters are on). System may run 5 to 10 mins but if air is leaking in it will start over again. Heat will expand fuel lines. Next how old is the fuel filter? If old change it and use a truck grade not a car grade filter. A good NAPA store can help you on this item.

John Blue
Syl,

OK, we move on. Is the engine air or liquid cooled? Did you check the fuel filter to see if you can see any water or rust in it? What is a the age on the engine? I would think around six years from 2005. Do you run it under load each month? Do you used a good fuel stabilizer like (Sta-Bil) in storage?
Syl
>>> My husband does use a good fuel stabilizer. He said he's not been able to see the filter as to the condition. We bought the Minnie new so the engine is 2005. I should also say that we have not been traveling with it much due to a health issue. Until last week it has been stored (indoors) since last Sept. We are also having AC problems (as seen on the forum as well). We replaced the AC 2 years ago and are now having the SAME issues with the AC (not cooling) as we did when we had problems 2 years ago. When we first bought the Minnie, it worked beautifully. We went out west and the AC and generator worked like a charm. Now, however, we have problems with both the AC and the generator. We are under warranty with the AC and will take it to the dealer who installed it tomorrow. We are traveling with an older golden retriever and need our AC. Thanks for the information you've provided. We just hoped to have an idea as to what might be wrong BEFORE we go to the dealer. We're pretty clueless. It's a shame that we can now travel, but are having MH woes such as the AC/generator.



QUOTE(John Blue @ Jul 21 2011, 08:25 AM) *

Syl,

OK, we move on. Is the engine air or liquid cooled? Did you check the fuel filter to see if you can see any water or rust in it? What is a the age on the engine? I would think around six years from 2005. Do you run it under load each month? Do you used a good fuel stabilizer like (Sta-Bil) in storage?

John Blue
Syl,

This is not that odd to have problems with generators. Some time back I found a lot of problems with an 8000 KW diesel Power Tech unit. Engine would only run a short time and cut off. We changed the secondary fuel filter and fuel pump. This helped a lot, next replaced the fuel shut down relay. Them found pins holes on fuel line from fuel pump to sound box, replaced that hose. Next found deep cracks in fuel line from sound box to primary Racor fuel filter. Next found small pin holes in fuel line from Racor on to the fuel tank. They can be fun to track down problems in fuel systems.
Florida Native
This is probably already been checked, but the fuel intake is located where you can't run below 1/4 tank. It might be sucking air from the main tank if you are right on 1/4.
bukhrn
I had the exact same problem with my Onan 4000, after listening to & mulling over many opinions, I took it to an RV Service Center, first they found a birds nest (which I never saw), I'm sure it wasn't helping it cool properly, but they also found a loose wire on the fuel cutoff switch, & a bad fuel pump.
When I went to pick it up, they had it running with the AC going, (it was HOT out), it ran for the entire hour & 10 min ride home.
While a little costly, it was well worth it, as I would have never found the problem(s) with it.
This is a "lo-fi" version of our main content. To view the full version with more information, formatting and images, please click here.